FAQ

Which Windows Server 2003 Versions are usable with SwyxWare v4.20 and higher ? (kb2520)

The information in this article applies to:

  • SwyxWare v6.02
  • SwyxWare v6.01
  • SwyxWare v6.00
  • SwyxWare v5.01
  • SwyxWare v5.00
  • SwyxWare v4.40
  • SwyxWare v4.20
  • Microsoft Windows Server 2003

[ Question | Answer | Links ]


Question

Which versions of Microsoft Windows Server 2003 are usable in conjunction with SwyxWare version 4.20 and higher ?


Answer

Microsoft offers the following versions of Windows Server 2003:

  • Web Edition
  • Standard Edition
  • Enterprise Edition
  • Datacenter Edition

Additionally a software bundle named "Small Business Server 2003" is available in a Standard and a Premium Edition. This bundle contains the Windows Server 2003 Standard Edition and is just a bundle of the Windows Server with some other Microsoft Server products (like Exchange, SQL etc.).

The best choise for using SwyxWare version 4.20 and higher is the Standard Edition of the Windows Server 2003. If possible, the Windows Server should be used exclusively for SwyxWare.

Because the "Small Business Server 2003" contains the Windows Server 2003 Standard Edition, it is ok to use SwyxWare with this server. But you have to make sure, that there is always enough memory and performance left for the SwyxWare. Please keep this topic in mind on assembling the hardware of the server. For more details regarding the hardware take a look at this KB article: Hardware Recommendations for SwyxWare (Overview) (kb2155)

The Enterprise and Datacenter Edition can also be used with SwyxWare, but keep in mind, that there should always be enough performance left for the SwyxWare!

It is not allowed to use the Web Edition, because Microsoft does forbid via the license agreement to use this Web Edition with other services than web services. Additionally the number of concurrent SMB network connections (which are necessary for SwyxIt!-Users) is limited to 10.

Note: starting with SwyxWare v6.01 previous installation of service pack 1 for Windows Server 2003 is required before upgrading or installation of SwyxWare!

Detailed information and feature comparisons regarding the Windows Server Versions can be found via the links at the end of this article.

 


Links

As far as software supplied or used by us, includes open source elements the additional terms under https://www.swyx.com/open-source apply in addition. An overview which products from the Swyx portfolio include open source elements and which open source license is relevant can be found under https://www.swyx.com/open-source.

The third-party contact information included in this article is provided to help you find the technical support you need. This contact information is subject to change without notice. Swyx in no way guarantees the accuracy of this third-party contact information nor is responsible for it's content.


Comment

Comment on this article



If we have any follow-up questions, where can we contact you?

E-Mail Address (optional)


Note

This feedback form can't be used for support requests. Those requests must be directed to your Swyx reseller or distributor.